読者です 読者をやめる 読者になる 読者になる

コンセントを挿し直さないと立ち上がりません。

サーバマシンが限界に近いので、動けば何でもいいので余ってるPCは無いかと、あまねく天下にふられナオンをつのったところ、後輩が名乗りを挙げた。

MEGA180

が、なんか訳ありPCだそうで、、、

「一度電源を落としたら、次回はコンセントを抜いて挿し直さないと起動しない」

との事。コンセント挿し直す?電源壊れてるんじゃね?怖っ。

まあ後輩の話ではそれで問題なく(というのか?)動いていたらしいので、頂く事に。としちゃん感激。

家に持ち帰って色々と調べてみたところ、どうもnForce2のチップセットと、UltraDMAモードで動いているPlextorのDVDドライブ PX-320Aとの相性が悪いようだ。

以下、実験詳細。

まず普通に起動してシャットダウン。再度電源を入れてみたところ、確かにBIOS画面の

「Detecting IDE Drivers...」

の所で止まってしまう。しばらく待ってみたがまったく動かない。ヤシガニ並だ。

とりあえず基本のCMOSクリアから、ということで、PCの分解をしようとしたが、さすがキューブベアボーン、分解がめっさめんどくさい。

VGAカード外して、メモリ外して、DVDドライブ外して、HDDを外し、、、CPUファン外さないとHDD外せないな、これ。

CPUファン外して、HDD外して、前面パネル外して、カードスロット外して、、、なかなか基盤が見えてこない。後、どこのネジを外せばええんじゃい。梅原並にブロック固すぎだ。

やっとこさ最下部の基盤に辿り着いてCMOSクリア。ばらしたままで起動、終了してみるが、やはり次回起動時にDetecting IDE Driversで停止した。

ならばIDEに問題が?ということで、まずSecondary Masterに接続されているDVDドライブを外してみたところ、問題なく起動出来る。となると、Secondary IDEかDVDドライブの問題か。

次にHDDをSecondary Masterに接続してみる。すると、、、

「Secondary IDE channel no 80 conductor cable installed」

むむ。この付属ケーブル40pinじゃねーか。変なところでケチんな>MSI。当時は80pinのスマートケーブルが無かったか高かったのかもしれんが。

80pinのスマートケーブルに変えてHDDを繋いだところ、問題なく起動できる。

それならということで、DVDドライブを接続してみたが、残念ながら起動できない。ちぇ。

と、ここで閃いた。そういえば昔のマザーで、UltraDMAのCD/DVDドライブを接続すると起動しないって話をどっかで聞いたな。まだ残ってたかなーとPIO接続のCDドライブを探しだし、接続してみたところ、問題なく起動できた。40pinのケーブルに戻しても問題ない。

ということで、間接証拠だが、犯人はDVDドライブのPX-320A。nForce2のチップセットと、UltraDMAモードで動いているDVDドライブとの相性問題だったようだ。にんともかんとも。

しかし今更CD-ROMドライブってのもなんなので、DVDドライブを付けて、起動時にはコンセントを挿し直すってことで妥協する。そんなに使わないしな。

それよりこのバラしたキューブを戻すのが大変だよ。ママン。

パーツを付ける順番が決まってる上に、電源とかIDEのケーブルぎちぎちに押し込まないと入らない。この辺がキューブの問題だな。小さくて格好はいいんだが。

試しに別のUltraDMA対応DVDドライブを接続してみたところ、BIOS画面が消えてからWindowsの進行状況バーが表示されるまで1分ほどかかった。何をしてるんじゃろ。不思議色マイハピネス。